Httpd dead but pid file exists

the apache service status shows httpd dead but pid file exists . I cannot stop the service but when i start it, it treats it as starting properly. There is nothing is the logs about this error.

php-v

PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/oci8.so' - libclntsh.so.11.1: cannot open shared object file: No such file or directory in Unknown on line 0
host (root) php -v
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/oci8.so' - libclntsh.so.11.1: cannot open shared object file: No such file or directory in Unknown on line 0
PHP 5.1.6 (cli) (built: May 22 2018 10:25:39)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies
host (root)[ /home/root ] ldd /usr/lib/php/modules/oci8.so
        linux-gate.so.1 =>  (0x0087d000)
        libclntsh.so.11.1 => not found
        libc.so.6 => /lib/libc.so.6 (0x00960000)
        /lib/ld-linux.so.2 (0x00567000)

Is there a way I can ignore /usr/lib/php/modules/oci8.so just to verify apache will start if this file is not in play? I actually think a file level restore of this file will fix it but I want to test that before I offer it as a solution

Have you tried installing the module again?

pecl install oci8

I said we may need to reinstall and was met with my boss gritting his teeth. I’d need approval, but it’s unlikely to be given until we exhaust all other options. I contacted my HQ who handles backups and asked if we can do a file level restore on our linux machines. France is closed currently and I won’t hear back until at earliest tomorrow–but they are very lax in their communication. I’ve had it take over a week to get a reply.

It wouldn’t be pecl install oci8 though. RHEL 5. That doesn’t seem to be a recognized command.

It looks like that is the command for PHP 7. Try this for PHP 5.1

pecl install oci8-1.4.10

https://pecl.php.net/package/oci8

You also need to have php-pear to use pecl

This writeup has some additional details

https://www.php.net/manual/en/oci8.installation.php