Server not SSL secured (LetsEncrypt / Certbot)

Hey everyone,

I’ve rented a VPS which runs CentOS 7.5 with DirectAdmin.
The only problem I had was that my domains where not SSL secured, so I tried to fix this by following tutorials.

The problem I have now is that my domains are offline and I can’t reach them.
The last thing I tried was this:

Command:
sudo certbot -d robin-kok.nl -d www.robin-kok.nl --apache

Error:

The apache plugin is not working; there may be problems with your existing configuration.
The error was: MisconfigurationError(‘Error while running apachect1 configtest.\n\nhttpd: Syntax error on line 52 of /etc/httpd/conf/httpd.conf : Syntax error on line 6 of /etc/httpd/conf/extra/httpd-phpmodules.conf : Cannot load /usr/lib/apache/mod_mpm_prefork.so into server: /usr/lib/apache/mod_mpm_prefork.so: indefined symbol: ap_set_listencbratio\n’,)

What are my next steps to figure out what the problem is on my server?

Thanks in advance!

1 Like

Why are you trying to use certbot, and not using DirectAdmin to get a cert from LE?

https://help.directadmin.com/item.php?id=648

It did not give me that option. I hosted a website before and it was possible, but now I can only:

Use server’s shared signed certificate.
Create your own self signed certificate.
Create a certificate request.
Paste a pre-generated certificate and key.

EDIT:

I read that to enable LetsEncrypt you need to edit directadmin.conf.
But I’m pretty new to Linux and I only have a console to work with, so it’s been a pretty steep learning curve.

What version of DirectAdmin? Can you share some screenshots? :slight_smile:

This is what you should see.

But you only have 4 tabs?

I think my DirectAdmin is very outdated.

Maybe, or you might just be using the wrong theme.

Try running this:

/usr/local/directadmin/directadmin v

It is v.1.53.2

EDIT:

Also, since my Apache server is offline I tried to start it again giving me this message:
Job for httpd.service failed because the control process exited with error code. See “systemdtl status httpd.service” and “journalctl -xe” for details.

https://forum.directadmin.com/showthread.php?t=56637

That’s over a year old :flushed: Take a backup, and try to upgrade DirectAdmin. Also, make sure your OS is up to date as well. Make a backup first.

https://www.transip.eu/knowledgebase/entry/134-how-keep-directadmin-installation-up-to-date/

What does this command show?

systemdtl status httpd.service

You really need to SSH into your server, so you can copy and paste the full errors.

Those screenshots don’t help much :-/

Make sure to use -l to grab logs with full description @Cookooloo

Is there anything else running on port 80 or 443. I had a problem earlier today with NGINX not starting. Apache was started and it was conflicting.

I will check those out when I get off work.
Thanks for helping me and sorry that I’m a huge noob when it comes to this. I hope I learn soon. :slight_smile:

@Cookooloo did you get this working?

1 Like